Esempio n. 1
0
 /**
  * @param adminobjectInterface full qualified name of the interface
  * @param adminobjectClass full qualified name of the implementation class
  * @param configProperty List of config propeties
  * @param id xmlid
  */
 public AdminObjectImpl(
     XsdString adminobjectInterface,
     XsdString adminobjectClass,
     List<ConfigProperty> configProperty,
     String id) {
   super(null);
   this.adminobjectInterface = adminobjectInterface;
   if (!XsdString.isNull(this.adminobjectInterface))
     this.adminobjectInterface.setTag(XML.ELEMENT_ADMINOBJECT_INTERFACE);
   this.adminobjectClass = adminobjectClass;
   if (!XsdString.isNull(this.adminobjectClass))
     this.adminobjectClass.setTag(XML.ELEMENT_ADMINOBJECT_CLASS);
   if (configProperty != null) {
     this.configProperties = new ArrayList<ConfigProperty>(configProperty);
   } else {
     this.configProperties = new ArrayList<ConfigProperty>(0);
   }
   this.id = id;
 }