Esempio n. 1
0
 /** {@inheritDoc} */
 public int hashCode() {
   final int prime = 31;
   int result = 1;
   result = prime * result + ((adminobjectClass == null) ? 0 : adminobjectClass.hashCode());
   result =
       prime * result + ((adminobjectInterface == null) ? 0 : adminobjectInterface.hashCode());
   result = prime * result + ((configProperties == null) ? 0 : configProperties.hashCode());
   result = prime * result + ((id == null) ? 0 : id.hashCode());
   return result;
 }