/** {@inheritDoc} */
 @Override
 protected void yAxisRenderYAxisSourceAsParameter(final IMath out) {
   try (final IMath math = out.compare(EMathComparison.fromEComparison(this.m_criterion))) {
     super.yAxisRenderYAxisSourceAsParameter(math);
     try (final IText number = math.number()) {
       if (this.isGoalValueLong() || (this.m_goalValueLong == this.m_goalValueDouble)) {
         number.append(this.m_goalValueLong);
       } else {
         number.append(this.m_goalValueDouble);
       }
     }
   }
 }
 /** {@inheritDoc} */
 @Override
 public final void callback(final IText element, final Map<Object, Object> properties) {
   element.append( //
       "This is a callback invocation printing the properties map: "); //$NON-NLS-1$
   element.append(properties);
 }