예제 #1
0
 byte[] implWrap(Key key) throws IllegalBlockSizeException, InvalidKeyException {
   return cipher.wrap(key);
 }
예제 #2
0
 /**
  * Wrap a key.
  *
  * @param key the key to be wrapped.
  * @return the wrapped key.
  * @exception IllegalBlockSizeException if this cipher is a block cipher, no padding has been
  *     requested, and the length of the encoding of the key to be wrapped is not a multiple of the
  *     block size.
  * @exception InvalidKeyException if it is impossible or unsafe to wrap the key with this cipher
  *     (e.g., a hardware protected key is being passed to a software only cipher).
  */
 protected byte[] engineWrap(Key key) throws IllegalBlockSizeException, InvalidKeyException {
   return core.wrap(key);
 }