Esempio n. 1
0
 /**
  * Creates an instance of DES cipher with default ECB mode and PKCS5Padding.
  *
  * @exception SecurityException if this constructor fails to verify its own integrity
  */
 public DESCipher() {
   SunJCE.ensureIntegrity(getClass());
   core = new CipherCore(new DESCrypt(), DESConstants.DES_BLOCK_SIZE);
 }