@Override
 public ServletContext getContext(String uripath) {
   ServletContext theContext = null;
   if (SecurityUtil.isPackageProtectionEnabled()) {
     theContext = (ServletContext) doPrivileged("getContext", new Object[] {uripath});
   } else {
     theContext = context.getContext(uripath);
   }
   if ((theContext != null) && (theContext instanceof ServletContextImpl)) {
     // theContext = this.context;
   }
   return theContext;
 }