Ejemplo n.º 1
0
 public AnnotationPart compileAnnotationToSODA(String annotationExpression) {
   String toCompile = annotationExpression + " select * from java.lang.Object";
   StatementSpecRaw raw =
       EPAdministratorHelper.compileEPL(
           toCompile,
           annotationExpression,
           false,
           null,
           services,
           SelectClauseStreamSelectorEnum.ISTREAM_ONLY);
   return StatementSpecMapper.unmap(raw.getAnnotations().get(0));
 }