/** {@inheritDoc} */
 @Override
 protected void yAxisRenderYAxisSourceAsParameter(final ITextOutput out) {
   super.yAxisRenderYAxisSourceAsParameter(out);
   out.append(EMathComparison.fromEComparison(this.m_criterion).getOperatorChar());
   if (this.isGoalValueLong() || (this.m_goalValueLong == this.m_goalValueDouble)) {
     out.append(this.m_goalValueLong);
   } else {
     out.append(this.m_goalValueDouble);
   }
 }
 /** {@inheritDoc} */
 @Override
 protected void yAxisRenderYAxisSourceAsParameter(final IMath out) {
   try (final IMath math = out.compare(EMathComparison.fromEComparison(this.m_criterion))) {
     super.yAxisRenderYAxisSourceAsParameter(math);
     try (final IText number = math.number()) {
       if (this.isGoalValueLong() || (this.m_goalValueLong == this.m_goalValueDouble)) {
         number.append(this.m_goalValueLong);
       } else {
         number.append(this.m_goalValueDouble);
       }
     }
   }
 }