Beispiel #1
0
 public void remove(T obj) throws SwarmException {
   remove(obj.getTypeId());
 }
Beispiel #2
0
 /**
  * Adds an object to the set.
  *
  * @param obj the object //TODO , its id or its specifier.
  */
 public void add(T obj) throws SwarmException {
   final TypeIdSpec key_spec = obj.getTypeId();
   JsonObject changes = new JsonObject();
   changes.set(key_spec.toString(), TRUE);
   change(changes);
 }