示例#1
0
 protected void engineInit(int opmode, Key key, AlgorithmParameters params, SecureRandom random)
     throws InvalidKeyException, InvalidAlgorithmParameterException {
   core.implInit(opmode, key, params, random, cipher);
 }
示例#2
0
 protected void engineInit(int opmode, Key key, SecureRandom random) throws InvalidKeyException {
   core.implInit(opmode, key, random, cipher);
 }
示例#3
0
 protected byte[] engineWrap(Key key) throws IllegalBlockSizeException, InvalidKeyException {
   return core.implWrap(key);
 }
示例#4
0
 protected AlgorithmParameters engineGetParameters() {
   return core.implGetParameters();
 }
示例#5
0
 protected byte[] engineUpdate(byte[] in, int inOff, int inLen) {
   return core.implUpdate(in, inOff, inLen);
 }
示例#6
0
 protected int engineUpdate(byte[] in, int inOff, int inLen, byte[] out, int outOff)
     throws ShortBufferException {
   return core.implUpdate(in, inOff, inLen, out, outOff);
 }
示例#7
0
 protected void engineSetPadding(String paddingScheme) throws NoSuchPaddingException {
   core.implSetPadding(paddingScheme);
 }
示例#8
0
 protected Key engineUnwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType)
     throws InvalidKeyException, NoSuchAlgorithmException {
   return core.implUnwrap(wrappedKey, wrappedKeyAlgorithm, wrappedKeyType);
 }
示例#9
0
 protected int engineGetOutputSize(int inLen) {
   return core.implGetOutputSize(inLen);
 }
示例#10
0
 protected void engineSetMode(String mode) throws NoSuchAlgorithmException {
   core.implSetMode(mode);
 }
示例#11
0
 protected int engineGetKeySize(Key key) throws InvalidKeyException {
   return core.implGetKeySize(key);
 }
示例#12
0
 protected byte[] engineGetIV() {
   return core.implGetIV();
 }
示例#13
0
 protected int engineGetBlockSize() {
   return core.implGetBlockSize();
 }
示例#14
0
 protected int engineDoFinal(byte[] in, int inOff, int inLen, byte[] out, int outOff)
     throws ShortBufferException, IllegalBlockSizeException, BadPaddingException {
   return core.implDoFinal(in, inOff, inLen, out, outOff);
 }
示例#15
0
 protected byte[] engineDoFinal(byte[] in, int inOff, int inLen)
     throws IllegalBlockSizeException, BadPaddingException {
   return core.implDoFinal(in, inOff, inLen);
 }